Issuer OIDC
orneos.eu
RS256 · JWKS public
Standard
OAuth 2.1
PKCE S256 · Refresh rotation
API Cloud
app.orneos.eu
WebDAV · OCS · DAV · Talk
Quotas par compte
5 apps
10 redirect URIs / app
Europäische Entwicklerplattform
Bauen Sie mit Orneos
Authentifizieren Sie Ihre Nutzer über einen standardkonformen OpenID-Connect-Anbieter (OAuth 2.1 + PKCE) und nutzen Sie die offenen Schnittstellen der Orneos Cloud.
OAuth 2.1 · OpenID Connect
Mit Orneos anmelden
OAuth-2.1-konformer OpenID-Connect-Anbieter: obligatorisches PKCE S256, RS256-JWT-Tokens, Refresh-Token-Rotation und Widerruf nach RFC 7009.
Single Sign-On ohne Weitergabe von Passwörtern
Vertrauliche (Server) und öffentliche (SPA / Mobil) Clients
Strikte Datenminimierung (Scopes openid, profile, email)
Mit Orneos anmelden
Mit Orneos anmelden
WebDAV · OCS · CalDAV · CardDAV · Talk
Orneos Cloud-API
Greifen Sie über offene Standardprotokolle und dedizierte App-Passwörter auf Dateien, Kalender, Kontakte und Orneos-Meet-Räume zu.
WebDAV-Dateien und OCS-v2-Freigaben auf app.orneos.eu
CalDAV- (RFC 4791) und CardDAV-Synchronisation (RFC 6352)
Orneos Meet / Talk Räume und automatisierte Nachrichten
Offene Architektur
Referenz-Endpunkte
Kein proprietärer Lock-in: Orneos implementiert OAuth 2.1, OpenID Connect Core 1.0, WebDAV, CalDAV und CardDAV.
Dienst
URL
Spezifikationen
OIDC Discovery
https://orneos.eu/.well-known/openid-configuration
Issuer https://orneos.eu · RS256 · S256 PKCE
Authorization
https://login.orneos.eu/oauth/authorize
response_type=code · code_challenge_method=S256
Token / Refresh
https://orneos.eu/oauth/token
authorization_code · refresh_token (rotation)
UserInfo
https://orneos.eu/oauth/userinfo
Bearer access token · openid profile email
Revocation (RFC 7009)
https://orneos.eu/oauth/revoke
POST token=...
Cloud WebDAV / CalDAV / CardDAV
https://app.orneos.eu/remote.php/dav/
Authentifizierung per App-Passwort
Cloud OCS API
https://app.orneos.eu/ocs/v2.php/
Header OCS-APIRequest: true